The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

HCL:Toshiba laptops

Jump to: navigation, search
Hardware Portal
Full systems Laptops - Desktops - Servers - Virtual Machines
Components Bluetooth adapters - Digital cameras - Firewire cards - Floppy drives - Gadgets - IDE + SATA cards - Keyboards - Motherboards - Monitors - Modems - Network adapters (Wired) - Network adapters (Wireless) - Optical media (CD, DVD, Blueray) - Phones, handsets, mobile/cell - Printers - RAID Controllers - Scanners - SCSI adapters - Sound cards - TV cards - UPS (Uninterruptible Power Supply) - Video cards - Web cameras
Acer - Apple - Asus - Compaq - Dell (incl. Alienware) - ECS - E machines - Everex - Fujitsu - Gateway - Hasee - Hitachi - Higrade - HP - IBM Lenovo - LG - Medion - MSI - NEC - Panasonic - Samsung - Sony - Toshiba - Other

Netbook Series

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
NB520 openSUSE 12.2 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-cross.png SD card works. Wireless, Brightness, and Volume FN keys work. Unique FN and special keys are not available. Suspend and screen lock works when closing lid. Toshiba Sleep N' Charge feature not available. Synaptic touchpad works without additional configuration. Maximum display resolution. Intel Atom N2800 supports 4GB RAM in openSUSE 32-bit.

Qosmio

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
Qosmio G25 SLED 10/openSUSE 10.1
openSUSE 10.3
Icon-checked.png 3D w/ NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png
Icon-question.pngnot tested
Icon-cross.png at least questionable
Icon-question.png
Modem not tested, but detected FnFx for function keys, external sound control doesn't work (dial on side), otherwise very functional
function keys works but not special keys (buttons above keyboard), external sound control works (dial on side), Haven't tried TV
Qosmio X505 openSUSE 11.4
up to
openSUSE 13.2
(including Tumbleweed)
Icon-checked.png 3D w/ NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
SD card reader works, but need to add
options sdhci debug_quirks=0x40
to /etc/modprobe.d/99-local.conf
For Digital Output (S/PDIF) to work, need to add
options snd-hda-intel model=auto
to /etc/modprobe.d/50-sound.conf
otherwise just Stereo and HDMI output will be detected
Qosmio X75-A openSUSE 13.2
openSUSE Tumbleweed
Icon-checked.png 3D w/ Bumblebee and NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
SD card Icon-checked.png NOTE: Once installation finishes, the laptop will freeze on subsequent boot attempts, this is due to nouveau driver crashing.
To avoid this, either install propietary NVidia drivers or disable the discrete graphics card using bbswitch, in any of the cases the nouveau driver MUST be blaclisted and a new initrd must be created.

Satellite

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
Satellite 2430-255 10.1 Icon-checked.png 3D supported with NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
CPU freq. scaling: Icon-checked.png
Modem detected, but not tested
Secure Digital Icon-cross.png
Use Omnibook kernel module for special keys, temp. monitors, & better ACPI
Satellite 2430-301 9.3 Icon-checked.png 3D supported with NVidia drivers Icon-checked.png Icon-checked.png NotApplicable.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem does fine
Satellite 4090xcdt 10.0 Icon-checked.png Icon-checked.png Icon-checked.png (PCMCIA) NotApplicable.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem detected but not tested Runs but very slowly (400MHz CPU)

Satellite A

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
Satellite A25-S279 10.1, 10.2, 10.3 Icon-checked.png (3D unsupported) Icon-checked.png Icon-checked.png Icon-checked.png (via http://madwifi.org/suse repository) NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
SD Icon-cross.png
Modem: Icon-question.png
Special Fn actions and multimedia keys working by loading the toshiba or toshiba_acpi modules and using a program to monitor these
Satellite A30-203 10.3 Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Satellite A60-202 10.2 Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
SD Icon-question.png
Modem: Icon-question.png
Multimedia key don't work, neither IR port
Satellite A70 10.0 Beta4 Icon-checked.png (3D unsupported) Icon-checked.png Icon-checked.png Icon-checked.png (needs kernel-default-nongpl package) NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
SD Icon-question.png
Modem: Icon-question.png
Special Fn actions and multimedia keys working by loading the toshiba or toshiba_acpi modules and using a program to monitor these
Satellite A75 10.2 Icon-checked.png 3D supported with ATI driver Icon-checked.png Icon-checked.png Icon-checked.png with madwifi NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png with "noapic" in kernel parameters
Processor Throttling: Icon-checked.png
Modem: Icon-checked.png
Card Reader: Icon-cross.png
need "noapic" in kernel parameters or else system locks randomly.
(note the machine doesn't use Toshiba Bios, so most standard Toshiba fixes don't work)
Satellite A100-788 11.0 Icon-checked.png 3D supported Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Suspend to
RAM: Icon-checked.png
Disk: Icon-question.png
Modem: Icon-question.png
Satellite A105 10.2, 10.3 Icon-checked.png 3D supported Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png
Processor Throttling: Icon-checked.png
Modem: Icon-checked.png
Card Reader: Icon-checked.png (Only tested with SD card)
Problems with rebooting, have to manually hold power button. Everything else works fine. Might have been kernel problem, tested with 10.2.
Satellite A110 11.0 Icon-checked.png 3D not initially supported - no ATI driver included Icon-checked.png Icon-checked.png Icon-cross.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png
Modem: Icon-cross.png Suspend to Disk didn't work from the liveCD, but did after installing to the hard drive. Madwifi may provide support for the wireless Atheros card, but the Kernel Module requires a currently unavailable update to the kernel before it can be installed.
Satellite A135-S2266 10.2 Icon-checked.png 3D supported with ATI Driver Icon-checked.png Icon-checked.png with madwifi Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-cross.png
Modem detected but not tested Speakers still work when headphones connected
Satellite A135-S2276 10.2 Icon-checked.png 3D supported with ATI Driver Icon-checked.png need BIOS Update V.1.20 or higher Icon-checked.png Icon-checked.png Atheros AR5006EG works with madwifi v0.9.2 NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem: Icon-checked.png
Satellite A135-S2326 10.3 Icon-checked.png 3D supported with ATI Driver Icon-checked.png Icon-checked.png Icon-checked.png Atheros AR5006EG 802.11 b/g works with madwifi v0.9.4 NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem detected but not tested can't get headphone/mic working
Satellite A135-S2326 11.1 Icon-checked.png 3D supported with ATI Driver http://en.opensuse.org/Additional_YaST_Package_Repositories Icon-checked.png Icon-checked.png Icon-checked.png Atheros AR5006EG 802.11 b/g use madwifi http://en.opensuse.org/Additional_YaST_Package_Repositories NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png but you often loose wireless
Modem detected but not tested
Satellite A135-S2326 11.2 Icon-checked.png3D supported after updates Icon-checked.png Icon-checked.png Icon-checked.png worked during install (Atheros) NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png but you often loose wireless
Modem not tested BEFORE booting installation F3 Video Mode:'TEXT' and F5 Kernel: 'Safe Settings' Do NOT use Automatic Configuration. Then only 'Failsafe' boot would work. Use 'Boot Loader' from YaST system section to clone/edit - Optional Command Line Parameters working for me: 'showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off processor.max_cstate=1' Now everything seems to work fine, including some 'Fn-Fkey' function keys and 3D desktop.
Satellite A135-S2326 CeleronM 11.3 32bit Icon-checked.png 3D Icon-checked.png no mic Icon-checked.png Icon-checked.png Icon-cross.png Suspend to
RAM: Icon-cross.png
Disk: Icon-cross.png
Icon-question.pngModem BEFORE booting installation F3 Video Mode:'TEXT' and F5 Kernel: 'Safe Settings'. ALWAYS use 'Failsafe' boot and after ALL updates you can 'Boot Loader' from YaST 'system section' to clone/edit - Optional Command Line Parameters: [11.3_32 bit use: showopts apm=off noresume nosmp maxcpus=0 powersaved=off nohz=off] brando@opensuse.org
Satellite A135-S2326 CeleronM 11.4 32bit Icon-checked.pngno 3D- Google-Earth OpenGL works fine Icon-checked.png no mic Icon-checked.png Icon-checked.png Icon-cross.png Suspend to
RAM: Icon-cross.png
Disk: Icon-cross.png
Icon-question.pngModem

Optioanal Kernel Command Line Parameters: showopts apm=off noresume nosmp maxcpus=0 powersaved=off nohz=off processor.max_cstate=1 nomodeset brando@opensuse.org

Satellite A200 10.3, 11.1, 11.2 Icon-cross.png (Use driver from ATI site, installed 'the hard way') Icon-checked.png Icon-checked.png Icon-checked.png Icon-cross.png All Bluetooth daemon dies after launching, do not detect my Logitech Bluetooth Mouse Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
None of the special function key or multimedia key works.
After installing ATI driver 8.40.7, 3D support for my ATI HD 2600 is enabled and resolution of LCD detected correctly, but you would never enter desktop with XGL enabled
oldcpu note: special function keys can be made to work with xmodmap command. This FD7 approach works on SUSE. http://www.immv.es/index.php?page=linux-on...oshiba-a200-12x
Satellite A300 11.0 Icon-checked.png Icon-checked.png Icon-checked.png config instructions Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-question.png
Disk: Icon-question.png
Satellite A305 11.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png works with generic external USB dongle if needed Suspend to
Disk: Icon-checked.png
RAM: Icon-checked.png Works good and fast (Just make sure to edit sleep.conf for removing and adding ath9k wireless module when suspending, see: http://en.opensuse.org/Pm-utils#Creating_your_own_hooks)
Modem detected but not tested. No tricks needed for installation. ACPI: The CPU fan doesn't turn off after it's put on (nor automatically, nor manually) A little few Fn keys are not recognized. All the other hardware and functions work out-of-the-box.
Satellite A500 11.2, 11.3, 11.4 Icon-checked.png Using proprietary NVIDIA driver. Icon-checked.png Icon-checked.png Icon-checked.png Use rtl8192se not tested Suspend to
Disk: Icon-checked.png
RAM: Icon-checked.png (suspend ONLY works with proprietary NVIDIA driver)
Modem not tested. Wifi and video drivers must be the proprietary ones to get video, suspend and wifi to work. http://www.smolts.org/client/show/pub_269e7730-ee4a-4bbd-8d79-19194f8f2957
Satellite A210-109 10.3 Icon-checked.png Using ATI driver. Icon-checked.png Icon-checked.png Icon-checked.png Use ndiswrapper not tested Suspend to
Disk: Icon-checked.png
RAM: Icon-checked.png (`s2ram -f` tested with ATi proprietary driver v8.3)
Modem not tested.
Card Reader recognized and works without problems.
Installation proceeds as usual, no specific tricks or problems there. You only need to get the windrivers for setting up WLAN chip with ndiswrapper. Toshiba Hotkeys not (yet) supported.
Satellite A215-S7428 11.0 Icon-checked.png Using proprietary ATI driver. Icon-checked.png Icon-checked.png not tested not tested Suspend to
Disk: Icon-checked.png
RAM: Icon-checked.png
Modem not tested. Installation proceeds as usual, no specific tricks or problems there. After install, done 1-click install of ati driver.

Satellite C

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
C645-SP4201L 12.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Icon-checked.png Out of the box
C655-S5061 13.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Icon-checked.png Out of the box
C660-10H 13.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Icon-checked.png Wireless device needs to be hardware enabled (Under Windows, Fn+F8)

Satellite E

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
E55t-A5320 openSUSE 13.2 Icon-checked.png OOB with default Intel drivers Icon-checked.png Questionable - perfect in 13.2 KDE but stopped working in 13.2 GNOME NotApplicable.png Not tested Icon-checked.png OOB with default Intel drivers NotApplicable.png Not tested but seems to work Suspend to
RAM: Icon-checked.png Suspend to
Disk: Icon-checked.png
Backlit keyboard Icon-cross.png Backlit keyboard works on first boot but doesn't work after initial sleep.

Satellite L

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
Satellite L10-101 10.0 Icon-checked.png Icon-checked.png Icon-checked.png (needs kernel-default-nongpl package) NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem detected but not tested No ACPI (smart battery system, ACPI after kernelpatch)
Satellite L30-10T 10.3 Icon-checked.png (Wide screen Needs ATI drivers, no 3D) Icon-checked.png needs alsa >= 1.0.16, default codec Icon-checked.png Icon-checked.png (Atheros AR5005G works w/ madwifi) NotApplicable.png Suspend to
RAM: Icon-checked.png S2RAM="-f "
Disk: Icon-checked.png HIBERNATE_METHOD=kernel
Not tested
Satellite L35-S1054 10.2 Icon-checked.png (3D Needs ATI drivers) Icon-checked.png Icon-checked.png Icon-checked.png (Atheros AR5005G works w/ madwifi) NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-cross.png
Modem not detected may need kernel module So Far Headphone Jack Does Not Work
Satellite L50-B-1U4 13.2 Template:? (3D Needs ATI drivers?) Icon-checked.png Icon-checked.png Icon-checked.png (Intel® Dual Band Wireless-AC 3160 works ?) NotApplicable.png Suspend to
RAM: Template:?
Disk: Template:?
Satellite L300-0D5 11.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem: Icon-question.png
SD-Card reader: Icon-checked.png
Webcam: Icon-question.png
DVD/CD: Detected. Not working out of box due to software issues.
Device Notifier does not detect CD, but does detect DVD.
Fnfx makes Fn button work for NUM keys, but Fn does not work for special keys (F keys).
External volume control dial works, Fn+Esc (Mute) works.
Satellite L300-11E 10.3 Icon-checked.png Icon-checked.png Icon-checked.png Icon-question.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png
Running the HD controller in the AHCI mode demands recreating the 'initrd' file by means of 'mkinintrd -m ahci' (as a root after booting in the controller's compatibility mode).
Satellite L300-11F 11.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png RTL8187b NotApplicable.png Suspend to
RAM: Icon-question.png
Disk: Icon-question.png
cam not tested yet Hot keys not tested yet
Satellite L300-11G 10.3 Icon-checked.png Need to install Intel driver Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png
Modem not tested, but detected
Satellite L305-S5944 12.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend not tested Modem: Icon-question.png
Card Reader: OK, card reader considered to be a USB storage device
Webcam: NotApplicable.png
All other hardware works out of the box.
Boot times are faster than any previous version of OpenSuSE,
Satellite L75D-A7283 13.1 Icon-checked.png (fgrlx 13.251-2 AMD drivers required) Icon-checked.png Icon-checked.png Icon-checked.png worked out of box! NotApplicable.png Icon-question.png Icon-question.png Grub2, change /etc/defaults/grub "GRUB_CMDLINE_LINUX_DEFAULT="showopts noresume nomodeset". Used AMD/ATI fglrx driver from respository AMD/ATI-FGLRX URL: http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/ to get smooth operation.

Satellite M

Model SUSE Linux
version
Hardware Support Remark:
Video Sound Ethernet Wireless Bluetooth Power
Management
Other
Satellite M30-304 10.0 Icon-checked.png (3D needs NVidia drivers) Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png
Modem detected but not tested 3D acceleration works as described on NVIDIA
Satellite M30-304 10.1 Icon-checked.png (3D needs NVidia drivers) Icon-checked.png Icon-checked.png Icon-cross.png (requires 'npw-firmware' package which is not available) NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-question.png
Modem detected but not tested Screen blanks when resuming from disk, coming back after considerable delay
Satellite M30X 11.1 Icon-checked.png (Needs ATI drivers: see ATI) Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-question.png
Modem detected but not tested
Satellite M40-288 10.0 Icon-checked.png (3D unsupported) needs ATI drivers Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png
Modem detected but not tested Hangs after install when starting X-server.
See here for more details.
Satellite M40-288 10.1 Icon-checked.png (3D unsupported) needs ATI drivers { {y}} Icon-checked.png Icon-checked.png Requires madwifi or ndiswrapper NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-checked.png (Requires noapic boot parameter)
Modem detected but not tested Shows garbage after starting X-server. Requires VESA or ATI drivers.
See here for more details.
Satellite M40X-286 10.0 and up Icon-checked.png (Needs ATI drivers: see ATI) Icon-checked.png Icon-checked.png Icon-checked.png (using madwifi) NotApplicable.png openSUSE up to 10.3: Icon-checked.png openSUSE 11: Icon-cross.png Modem detected but not tested. Internal card reader detected, at moment not tested. After installation, it won't boot into GUI, you have to log-in root into console, then run SAX2 and reboot (OpenSUSE 10.2). After suspend wireless won't connect anymore: see bug 222529.
Satellite M45-S265 10.1 Icon-checked.png
Some Open GL issues to be resolved.
Icon-checked.png
Works after adding pci=noapic to boot
Icon-checked.png Icon-checked.png Icon-checked.png
BT USB Adaptor Works
Suspend to
RAM: Icon-question.png
Disk: Icon-question.png
Not Tried
Frequency scaling of CPU: Icon-checked.png
Battery: Icon-checked.png
Dimming of display: Icon-cross.png
Modem: Icon-question.png, Detected but not tested
Firewire: Icon-checked.png
PCMCIA: Icon-question.png
Cardreader: Icon-question.png
Not Installed - Optional Component
Satellite M45-S331 10.1 Icon-checked.png Icon-checked.png Icon-checked.png, but crashes from time to time and needs a "rcnetwork restart" Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-checked.png
Disk: Icon-checked.png, but afterwards no network connection can be established
Frequency scaling of CPU: Icon-checked.png
Battery: Icon-checked.png
Dimming of display: Icon-cross.png
Modem: Icon-checked.png, but needs manual installation of slmodem (v2.9.11, compile with ALSA support!)
Firewire: Icon-checked.png
PCMCIA: Icon-question.png
Cardreader: Icon-cross.png
Satellite M60-167 13.1 (13.2) Icon-checked.png (after Radeon driver update) Icon-checked.png Icon-checked.png Icon-checked.png Not tested Suspend not tested NotApplicable.png Installed from openSUSE-13.1-KDE-Live-i686.iso, using external vga monitor, internal display blank, after install completed added repository http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_13.1 and updated all to newer versions, after which external monitor not necessary. Also works with latest os ok, factory, openSUSE 20140818 (Harlequin)
Satellite M70-244 10.0 Icon-checked.png (ATI drivers) Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
RAM: Icon-cross.png
Disk: Icon-cross.png
NotApplicable.png
Satellite M100 10.3 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-cross.png Suspend to
Disk: Icon-question.png
Modem not detected 10.3 standard install and it supports all the following features of this laptop - (1)Finger print reader works, (2) Built-in card reader works with SD - tested with 2GB SD card (no driver yet for Memory Stick)
Noted the following issues:
  • When booting from previous suspend to disk, GUI is blank only mouse pointer visible
  • Internel bluetooth not works, but a 5 year old bluetooth tangle works
  • The volume control applet is mis behaving
  • gnome-terminal loses focus on maximize on compiz fusion
    Overall, i get all toshiba M100 functionality straight out of 10.3 install, very impressed.
  • Satellite P

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Satellite P25-487 10.2 Icon-checked.png (nVidia driver) Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    Modem: Icon-question.png
    CD buttons Icon-cross.png
    Satellite P100-115 10.1 Icon-checked.png 3D supported with NVidia drivers. But graphics card fan never turns on-overheating problem Icon-cross.png (with acpi=off there is sound)
    (New info acpi_osi=!Linux gives sound)
    Icon-checked.png NotApplicable.png NotApplicable.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-question.png
    Modem not tested There is some problem with ACPI or video driver, because graphics card fan doesnt turn on and graphics card gets overheated. Solution is acpi=off and having fans on all the time.
    oldcpu: reference for acpi_osi=!Linux fix: http://www.suseforums.net/index.php?showtopic=40851&hl=
    Satellite P100-PSPA4E 10.3 Icon-checked.png 3D supported with NVidia drivers. Icon-cross.png (fixing the DSDT will solve the problem) Icon-checked.png Icon-checked.png Icon-checked.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-question.png
    Modem not tested There is some problem with DSDT, but the below referenced link gives you very concise instructions on how to fix it. Please disregard the fact that the instructions were written for a P100-105. Also, these instructions were tested with BIOS versions 2.40, 3.30 and 3.80.
    DSDT fix: http://http://www.linuxquestions.org/questions/susenovell-60/howto-fix-acpi-ich7-family-conexant-driver-on-toshiba-p100105-series-531575/
    Satellite P105-S9337 11.2 Icon-checked.png 3D supported with NVidia repo added Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Fingerprint Reader
    Icon-question.png Modem
    Icon-question.png Mediacard Reader
    Fingerprint reader needs to have YaST component installed.
    Modem not tested
    Mediacard Reader not tested but shows in 'lsusb'
    Satellite P200 11.0 Icon-checked.png ATI drivers installed correctly with one click install Icon-checked.png Icon-checked.png Icon-checked.png minor discovery problems (switch wlan before boot) Icon-checked.png install omnibook modprobe omnibook ectype=14 Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    modem:Icon-cross.png
    card reader: Icon-checked.png
    webcam:Icon-checked.png install gspcav
    multimedia keys: Icon-checked.png see xmodmap
    compiz: Icon-checked.png update
    Satellite P200D-130 11.1 Icon-checked.png works with Mesa-Project-Driver,
    seems better than ATI-driver in 11.0
    No 3D-support
    Icon-checked.png Icon-checked.png Icon-checked.png with madwifi-free [1]

    New Info: works with ath5k-driver out of the box!
    NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    In both cases W-LAN losses connection after re-start
    New Info: problem does not appear with ath5k-WLAN-driver!
    modem:Icon-cross.png
    card reader: Icon-checked.png
    webcam:Icon-checked.png install gspcav
    multimedia keys: Icon-checked.png see xmodmap
    compiz: Icon-checked.png update
    Didn't test everything, nearly all worked out of the bo
    Satellite P300D-10U 11.0 Icon-checked.png only with ATI Proprietary Linux Display Driver Icon-checked.png Icon-checked.png config instructions Icon-question.png not tested Icon-checked.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    Webcam: Icon-checked.png After install and reboot, use Ctrl+Alt+F1, logon as root.
    1. Configure LAN config instructions
    2. Add ATI Proprietary Driver repository and install driver. Then use: aticonfig --initial to configure driver. Then restart X server.
    Satellite P300D-10U 11.2 Icon-checked.png radeonhd Icon-checked.png Icon-checked.png Icon-checked.pngIcon-question.png not tested (possibly works) Icon-question.png After reboot of a notebook with the wi-fi switch on the front panel in position off - doesn't work at any position of the wi-fi switch Icon-question.png not tested Webcam: Icon-checked.png
    SD card reader: Icon-checked.png
    XD card reader: Icon-cross.png

    Satellite R

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Satellite R15-S829 11.0 Icon-checked.png Needs Intel driver 915resolution Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    (not working)
    Tablet functions:
    Icon-checked.png Pen working.
    Icon-cross.png Tablet buttons not working.
    Toshiba buttons not working
    Even with fn-fx installed.
    Modem not tested, but detected.

    Satellite T

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Satellite T110D 11.3 Icon-question.png Out of the box, choppy at watching online streaming video at full screen, but great at everything else including 3D and DVD movies.

    ATi driver for HD 2000-series and newer. does not work, X-windows will not come up unless in failsafe mode.
    Icon-checked.png Output volume is low, property of laptop I assume. To get the mic to work, set capture on Mic F (there are 4 mics for some reason), Select the Capture, and set the Analog Mic Boost to 40 dB. Icon-checked.png Works out of the box. (WOotB) Icon-question.png Did not try. Icon-question.png Did not try. Suspend to
    RAM: Icon-checked.png (WOotB)
    Disk: Icon-checked.png (WOotB)
    Modem: NotApplicable.png
    Webcam: Icon-checked.png (WOotB)
    If you install MS Windows 7 on it first, it is not possible to install OpenSuSE as a dual boot as there will be 4 primary partitions on it before you install OpenSuSE (one or 2 of them being the Windows restoration partitions as there is no optical drives on this machine. Once I deleted the Windows partion (the largest partition), I was able to install OpenSuSE Live KDE from a live USB flash drive. This left the Windows restoration partitions (I hope) in case I have to consider the unpalatable so that my son can use it in school. So, I don't believe I have a Dual boot, just the possibility of re-installing MS Windows. I do not know what would have happened if I had installed OpenSuSE first.

    Audio and video tested with Skype, and audio only worked after an update and reboot.

    Highly recommend using an external DVD drive over a Live USB flash drive.

    Nice end result, even with choppy streaming video.

    Satellite U

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Satellite U300-PSU34C 10.3 Icon-checked.png Using Intel driver. Needs 815resolution on 10.2 Icon-checked.png Get the latest Alsa drivers, do ONLY 'make' for the drivers, install, and configure in Yast. Edit modprobe.d/sound and set as follows to get it working: 'options snd-hda-intel enable=1 index=0 model=ref position_fix=1' Icon-checked.png Works with 10.3. 10.2 needs newer module. Icon-checked.png with latest ndiswrapper and net5211.inf. Card is NOT supported by madwifi yet (AR5006EG). If you have already installed madwifi, you MUST blacklist the ath_pci module for it to work. NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-question.png
    Modem: Icon-cross.png Unsupported as yet, see: http://linmodems.technion.ac.il/bigarch/archive-seventh/msg00915.html
    Webcam: Icon-checked.png Works out of the box with 10.3
    No Hotkeys, as toshiba_acpi module does NOT support this laptop yet.

    Satellite X

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Satellite X205-S9800 11.1, 11.2 Icon-checked.png (3D w/ Binary NVIDIA drivers)
    For 11.2 vmalloc=256MB parameter is needed
    Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    SD: Icon-question.png
    Modem: Icon-question.png
    Finger print reader: Icon-checked.png
    Webcam: Icon-checked.png
    Special Fn actions and multimedia keys working by loading the omnibook module ( needs sources from trunk) and using a program to monitor these (like KToshiba >= 0.4.0).
    Sound works out of the box, however, newer ALSA drivers are needed to get full sound support.
    Composite works by adding the following to Device section in xorg.conf:
    Option "RegistryDwords" "PerfLevelSrc=0x2222; PowerMizerLevel=0x1; PowerMizerLevelAC=0x1"
    In 11.2, the video.ko kernel module crashes, you need to blacklist the module to prevent it from loading automatically.

    Satellite Pro

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Satellite Pro L20 10.1* Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    Modem not tested Hangs after install when starting X-server.
    See here for more details.
    Satellite Pro SP 4600 10.2
    10.3
    Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    Modem: detected but not tested WLAN with PCMCIA card: Icon-checked.png
    Satellite Pro SP 6000 10.2
    10.3
    Icon-checked.png Icon-checked.png add usergroup 'audio' for all users Icon-checked.png NotApplicable.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    Modem: Icon-cross.png WLAN with PCMCIA card: Icon-checked.png

    Portege

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Portege R100 10.3 Icon-checked.png with grub vga=791,
    sax not working
    Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    Modem not tested, but detected
    Portege R200 11.0 Icon-checked.png with grub vga=0x318 Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    Modem not tested
    Portege M200 10.0 Icon-checked.png 3D supported with NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-question.png
    SD Icon-question.png
    Modem: Icon-question.png
    Tablet function needs some extra manual attention, though sax can be used for most of the setup.
    Portege M200 10.2 Icon-checked.png 3D supported with NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-question.png
    SD Icon-question.png
    Modem: Icon-question.png
    Tablet not fully functional yet. Everything else-Excellent!
    Portege M300 10.2 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png (with madwifi) NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    Modem: Icon-question.png Rebooting does not seem to work when dual-booting with Windows. Fine on its own.
    Portege M600 10.3 Icon-checked.png Icon-cross.png Use latest alsa repositorie (multimedia:/audio/) Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    CPU freq. scaling: Icon-checked.png
    SD: Icon-checked.png
    Modem: Icon-question.png
    Webcam: Icon-checked.png
    Media Keys: Icon-checked.png
    No problems with vista dual-booting
    Portege 7140ct 10 beta 3 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    Modem not tested, but detected
    Portege Z830-S8302 12.1 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Not tested. Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    Trackpad multitouch works. Connect or disconnect power or network while suspended to disk often lead to OS crash after resume.

    Tecra

    Model SUSE Linux
    version
    Hardware Support Remark:
    Video Sound Ethernet Wireless Bluetooth Power
    Management
    Other
    Tecra A3 10.0 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    Modem not tested
    Tecra A7 10.2 Icon-checked.png Needs ATI proprietary driver Icon-checked.png Icon-checked.png Icon-checked.png Icon-question.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-cross.png
    Modem not detected/not working
    Tecra A8 10.2 Icon-checked.png Icon-checked.png Add model=basic to snd-intel-hda line in /etc/modprobe.d/sound Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    Modem not tested
    Tecra A8 10.3 Icon-checked.png Icon-checked.png Installed alsa-firmware and added model=basic to snd-intel-hda line in /etc/modprobe.d/sound Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    Modem not tested
    Tecra A8 PTA83E 11.0 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Needs the module "toshbt" to work Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    Modem not tested The screen resolution and the touchpad were not properly set up, I had to modify xorg.conf manually. If you want bluetooth, you need to load the toshiba_acpi module (comes with opensuse's default kernel) and after that toshbt module (does not come with opensuse's default kernel, you need to download it and compile it separately). Thanks to everybody involved in releasing this fine distribution.
    Tecra M2 11.0 Icon-checked.png Best with NVidia drivers Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-cross.png
    Modem not tested Had to modify xorg.conf manually for ALPS touchpad to be useful.
    Tecra S1 10.3 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-cross.png
    Disk: Icon-checked.png
    Modem not tested
    Tecra S1 11.0 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-checked.png
    Disk: Icon-checked.png
    Modem not tested
    Tecra S3 10.2 Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-checked.png
    Modem not tested
    Tecra 8000 10.0 RC1 Icon-checked.png Icon-checked.png Icon-checked.png(PCMCIA Card) NotApplicable.png NotApplicable.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-checked.png
    Modem not tested Sound driver doesn't support `Suspend Computer`
    Tecra 8000 11.1 Icon-checked.png Icon-checked.png Icon-checked.png (With Port Replicator) Icon-checked.png (With ACX111 PC-Card) NotApplicable.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-question.png
    Modem not tested 256Mb Memory , 8 GB Hd , 366Mhz Proc
    Tecra 9100 11.1 Icon-checked.png Icon-checked.png Icon-checked.png (With Port Replicator) Icon-checked.png NotApplicable.png Suspend to
    RAM: Icon-question.png
    Disk: Icon-question.png
    TV output and modem and PCMCIA not tested.
    SD card reader works.
    0.75 GB RAM Memory , 80 GB Hd , 1.8G M-4 Proc. Lid power switch causes PC to sleep.