SDB:Create a Live USB stick using macOS
There is a dedicated article about how to Create a Live USB stick using Linux and how to Create a Live USB stick using Windows
Version: 12.2+ This applies to openSUSE 12.2 and above.
Using Etcher
- Download the current ISO image of openSUSE Leap or Tumbleweed. The filename ends with ".iso".
- Download, install and start Etcher
- Select the openSUSE .iso file you just downloaded using the "Flash from file" button.
- Plug a USB drive into you computer, if it's the only drive connected to your computer, it will be automatically selected. If not, select it.
- Click "Flash". The process of burning can last from 1 to up to 30 minutes depending on your drive and on the iso file.
- Unplug the USB drive. It now contains a bootable openSUSE installation media.
Using Command Lines
Find Block Device
Plug-in your USB stick and find what "/dev/diskN" it is mapped to by opening Terminal (where "N" stands for "disk0", "disk1", "disk2" etc). To do so, please execute:
# diskutil list
This will print out the list of currently mapped devices/partitions. Find the USB using "NAME" column. Then note the corresponding /dev/diskN, where "N" is for index of your disk. For example:
/dev/disk2 #: TYPE NAME SIZE IDENTIFIER 0: FAT32 2.0 GB disk0 1: USB2 2.0 GB disk0s1
In this case "/dev/disk2" is the one we want.
Unmount USB Stick
Unmount the USB stick
# diskutil unmountDisk /dev/diskN
Where /dev/diskN is the one you have found in previous step as per our example it would be "/dev/disk2".
Write ISO to USB
Write the content of the ISO file:
# sudo sh -c "cat /path/to/downloaded.iso > /dev/rdiskN"
/dev/rdiskN is the same disk you have found previously, with an r in front. r is for raw disk, as writing to /dev/rdisk2 is much faster than writing to /dev/disk2. You will be prompted for the administrator's password.
No progress is shown while writing this way. If you have Homebrew or MacPorts, you can get a progress bar by installing the "pv" command and using that instead of "cat".