Archive:Most annoying bugs 11.2 dev

Jump to: navigation, search
The most annoying bugs and their suggested workarounds:
For general information about reporting bugs, see Submitting Bug Reports. This page is not about listing all your own bug reports but issues visible to a majority of users or bugs which are (expected to) repeatedly reported to Bugzilla.

To directly report a bug against openSUSE 11.2, here's a shortcut.


Final Release

openSUSE 11.2 RC2

General

  • The Net ISO images will call the Factory repository. The URL for repositories needs to be changed from /factory/repo/oss to /factory-snapshot/repo/oss manually.
  • Unnecessary localisation files for myspell and openoffice-thesaurus as recommended packages, about 400 MiB preselected for install by yast software manager on first run (Bug #551003).
  • Region is US, on local installation (Bug #550874)
  • Installer does not detect or set up other installed Linux distributions Bug #548993
  • Serious problems if you have existing data on a software RAID1 array. Bug #548132 - YaST2 automatic repair from DVD still fails to recognize RAID1 array; 11.2 unable to recognize 11.1 raid filesystem.
  • Installation doesn't finish when rebooting for the first time. As soon as it gets to configuring the hardware the gui disappears and closes the installation program down.

GNOME

  • Authentication is required to configure drive spindown timeout (Bug #548858)
  • GDM pops up for a while although is used autologin (Bug #551116)

openSUSE 11.2 RC1

General

  • ksoftirqd 100% cpu load bug has not gone: 100% disk load instead (Bug #465039)
  • no more sound output Bug #550654
  • Messages "not a regular file or has tail and normal blocks" on console during boot caused by preload (Bug #546359)
  • "soft" lockup on shutdown in qemu (Bug #546838)
  • all repos are lost on update (Bug #543468)
  • resolv.conf is empty after upgrade therefore no dns (Bug #546213), Fix: sudo /sbin/netconfig update -f
  • Dell USB wheel mice don't work (Bug #522287)

GNOME

  • Gnome's icon is only partially visible during the desktop environment selection phase of installation (Bug #545753)
  • sonar: gdm panel contains GtkComboBox that are unreadable (Bug #544079)
  • Restart fails to restart computer (Bug #540482)

KDE

  • ktimetracker: menues and toolbars are totally broken (Bug #544274)
  • OpenOffice.org KDE4 file dialog misses text (Bug #529640)

XFCE

  • xfwm4 is not started on login (Bug #530226), Work-Around: start manually with <Alt-F2> xfwm4 <Enter>

openSUSE 11.2 Milestone 8

KDE

GENERAL

INSTALLATION

  • installation not possible on HP/Compaq Proliant with SMART array controller (Bug #538351)
  • ATI-cards: X: display stays dark: move /etc/X11/xorg.conf.install to /etc/X11/xorg.conf; look here for further instructions.
    • I'm not sure if I have the same issue (IBM T60/radeonhd), but it helps when I change the brightness with Fn+Home/End after the screen goes black (usually after resolution change or X start) --prusnak
  • YaST keeps downloading the package despite aborting the installation (Bug #545106)
  • Grub Error 17 after instalation on RAID1 (Bug #539616)
  • Update repo is named silly (Bug #542792)

GNOME

  • GNOME Live system asks for root password to mount file system after installation (Bug #537343), work-around: just "Cancel"
  • Autologin instead restart in Gnome (Bug #532090)
  • Restart fails to restart computer (Bug #540482)
  • ^C and other shortcuts doesn`t work in gnome-terminal when booted LiveCD with russian language as default (Bug #540494), work-around - re-add US English keymap or use xterm.

openSUSE 11.2 Milestone 7

  • grub, bootsplash and splashy still use 11.1 artwork (Bug #538949, Bug #538955, Bug #533989)
  • License information on install is displayed in German (Bug #533026)
  • HAL may crash, leaving XOrg without keyboard and mouse (Bug #537452), work-around: update with 'hal' package from Base:System
  • Intel 4965 wireless is completely broken (Bug #537112)
  • KDE desktop
    • Dolphin cannot mount fixed partions due to PolicyKit restrictions (Bug #533246), work-around: polkit-auth --obtain org.freedesktop.hal.storage.mount-fixed
  • GNOME desktop
    • Live system asks for root password to mount file system (Bug #537343), work-around: just "Cancel"
    • YaST Control Center cannot be started (Bug #537470), work-around: see comment 8 of bug report
    • PackageKit permanently requires authentication (Bug #538353), work-around: apply comment 7 of bug report
    • ^C and other shortcuts doesn`t work in gnome-terminal when booted LiveCD with russian language as default (Bug #540494), work-around - re-add US English keymap or use xterm.
    • gnome-system-monitor eats much memory (Bug #519015)
    • GNOME desktop: Live system asks for root password to mount file system (Bug #537343), work-around: just "Cancel"
  • Encrypted root hangs with "waiting for /dev/system/root" to appear (Bug #535013), work-around: add cryptomgr to %udevmodules in /lib/mkinitrd/scripts/boot-luks.sh
  • ATI-cards: X: display stays dark: move /etc/X11/xorg.conf.install to /etc/X11/xorg.conf; look here for further instructions.
    • I'm not sure if I have the same issue (IBM T60/radeonhd), but it helps when I change the brightness with Fn+Home/End after the screen goes black (usually after resolution change or X start) --prusnak
  • ksoftirqd 100% cpu load bug has not gone: 100% disk load instead (Bug #465039)
  • grub on reiserfs on root filesystem has issues on thawing from s2disk: very, very slow (Bug #538795). Solution: use a separate /boot partition as ext2.
  • It is impossible to install system on a LVM partition which sits on top of RAID 0/1 stripe (Bug #525237)
  • hint: Thunderbird: click on the left/right button on the caption of the inboxes view to view all inboxes separately (traditional view).
  • Firefox: bookmarks can not be added any more Bug #540629
  • Thunderbird: can not select default browser Bug #540631
  • pairing of bluetooth devices does not work in user mode Bug #513123

openSUSE 11.2 Milestone 6

  • GNOME Live-CDs miss Evolution
  • 2nd stage of Live-CD installation runs in text-mode (Bug #533159)
  • YaST Qt control center requires double click to start modules (Bug #525287)
  • Calling "Install Software" from start menus of both KDE and GNOME fails, work-around: start module over YaST Control Center (Bug #529510, Bug #529137)
  • Downloads/updates with aria/metalink support (repo-oss, repo-non-oss) will fail, work-around: "export ZYPP_ARIA2C=0" (Bug #532575)
  • You cannot install the Btrfs filesystem. (/sbin/mkfs.btrfs: No such file or directory) (Bug #537071)

openSUSE 11.2 Milestone 5

  • x86_64 DVD ISO doesn't fit on DVD (Bug #529098)
  • Live-CD ISOs will boot from USB on some hardware only
  • Live-CD installation will throw error or even fail (Bug #529175)
  • The update of factory-snapshot/repo/oss/ has happened a build after Milestone 5 state
  • X display is initially messed up within VirtualBox machines with big video memory, work-around: reduce video memory size or switch to first console and back (default: right Ctrl-F1, right Ctrl-F7) (Bug #522025)
  • Calling "Install Software" from start menus of both KDE and GNOME fails, work-around: start module over YaST Control Center (Bug #529510, Bug #529137)
  • kdesu does not work (for eg starting YaST), work-around: 'su -c "unset DBUS_SESSION_BUS_ADDRESS;yast2"' (Bug #529113, Bug #482749)
  • GNOME Live-CD misses Tomboy (and desktop start complains about), Beagle, GNOME-Do
  • X server might hang in runlevel 5 before the logon occurs (Bug #528397). Live-CD workaround: boot with textmode=1, root login, init 5 ;installation workaround: See comment #3 of this bug report
  • KDE4 KNetworkManager doesn't show wireless networks (Bug #528083). Workaround: See comment #3 of this bug report
  • Reboot/Shutdown not possible from GNOME. fix: update the gnome-session package from Factory (Bug #531538)
  • Kernel is compiled with KMS support which causes DRI issues for Radeon chips (Bug #527910). Workaround: add boot parameter radeon.modeset=0 See also comment #4 of this bug report

openSUSE 11.2 Milestone 4

  • Live-CDs boot up not with resolution selected/default at boot menu (Bug #525243)
  • X display is initially messed up within VirtualBox machines with big video memory, work-around: reduce video memory size or switch to first console and back (default: right Ctrl-F1, right Ctrl-F7) (Bug #522025)
  • Some packages are missing from KDE Live-CDs (eg plasma-addons and OpenOffice_org-kde4) (Bug #525094)
  • Installation shows an empty error box while configuring boot loader, but it works fine (Bug #515529)
  • Live-CDs will not boot from USB if system has a cdrom-drive (Bug #496505)

openSUSE 11.2 Milestone 3

  • Boot menu and /etc/SuSE-release identify it as 11.2 Milestone 2
  • Installation shows an empty error box while configuring boot loader, but it works fine (Bug #515529)
  • RPMs with scripts to modify user db hang during updates (Bug #510788) (workaround: disable nscd)

openSUSE 11.2 Milestone 2

  • "Open Terminal" in nautilus crashes (Bug #508293)
  • KDE4.3 mixer crashes
  • Addons do not fit on a CD
  • Live CDs do not follow video mode selection
  • Artwork looks pretty much like 11.1
  • Systems with root on LVM will not boot (Bug #505670) (Exists for Milestone 3, fixed later in Factory)

openSUSE 11.2 Milestone 1