Home Wiki > openSUSE:Supported ARM boards
Sign up | Login

openSUSE:Supported ARM boards

tagline: From openSUSE

Release supported platforms

Community supported platforms

Not yet officially supported but known working platforms

Board Status

Factory

Warning TODO


13.1

Board Video out 2D/3D accel Video accel Audio In Audio Out USB UART Ethernet WiFi SD/MMC On-board memory
(NAND, eMMC,...)
SATA KVM support Misc
Beagleboard N/A N/A
Beagleboard xM Icon-cross.png Icon-cross.png Icon-cross.png Icon-question.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png N/A Icon-checked.png N/A N/A N/A No GFX output on BB xM rev. B
BeagleBone Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png N/A Icon-question.png Icon-question.png N/A N/A
BeagleBone Black Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png N/A Icon-question.png Icon-question.png N/A N/A
Pandaboard (ES) Icon-cross.png Icon-cross.png Icon-cross.png Icon-question.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-question.png Icon-checked.png N/A N/A N/A To get sound output, run alsamixer and switch Headset Left Playback and Headset Right Playback from Off to HS DAC and set Headset level to 100.
Efika MX Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png N/A N/A
Versatile Express (QEMU) N/A Icon-question.png
Calxeda Highbank N/A N/A N/A N/A N/A N/A Icon-question.png Icon-question.png N/A Icon-question.png N/A Icon-question.png Icon-question.png
i.MX53 Loco Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png N/A Icon-question.png N/A Icon-question.png N/A
CuBox Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png N/A
Origen Board Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png N/A Icon-question.png Icon-question.png N/A N/A N/A
Arndale Board Icon-cross.png Icon-cross.png Icon-cross.png Icon-question.png Icon-question.png Icon-question.png Icon-checked.png Icon-question.png Icon-question.png Icon-checked.png N/A Icon-question.png Icon-question.png
Samsung Chromebook Icon-checked.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-checked.png N/A N/A Icon-checked.png Icon-checked.png Icon-question.png N/A Icon-question.png
Raspberry Pi Icon-checked.png Icon-checked.png Icon-checked.png Icon-question.png Icon-checked.png Icon-checked.png Icon-question.png Icon-checked.png N/A Icon-checked.png N/A N/A N/A Boot partition must be resized. See: HCL:Raspberry_Pi#Known_Issues

12.3

Warning TODO

12.2

Board Video out 2D/3D accel Video accel Audio In Audio Out USB UART Ethernet WiFi SD/MMC On-board memory
(NAND, eMMC,...)
SATA KVM support Misc
Beagleboard N/A N/A
Beagleboard xM Icon-checked.png Icon-cross.png Icon-cross.png Icon-cross.png Icon-cross.png Icon-checked.png Icon-checked.png Icon-checked.png N/A Icon-checked.png N/A N/A Icon-cross.png X11 not accelerated
Pandaboard (ES) Icon-checked.png
(HDMI only)
Icon-cross.png Icon-cross.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-checked.png N/A Icon-cross.png Video out only works properly on the HDMI connector
Video is not accelerated
The board can be unstable under high load
Efika MX Icon-cross.png Icon-cross.png Icon-cross.png Icon-question.png Icon-question.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-question.png Icon-checked.png Icon-checked.png  N/A Icon-cross.png No graphics (driver is not upstream)
Versatile Express (QEMU) N/A Icon-cross.png Xorg doesn't work in QEMU
Calxeda Highbank N/A N/A N/A N/A N/A N/A Icon-checked.png Icon-checked.png N/A Icon-checked.png N/A Icon-checked.png Icon-cross.png
i.MX53 Loco Icon-cross.png Icon-cross.png Icon-cross.png Icon-question.png Icon-question.png Icon-checked.png Icon-checked.png Icon-checked.png N/A Icon-checked.png N/A Icon-cross.png Icon-cross.png No video (drivers not upstream)
CuBox Icon-checked.png Icon-question.png Icon-question.png Icon-question.png Icon-question.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-cross.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-cross.png uses xorg-dovefb video driver. 2D/3D acceleration possible but not (yet) supported
Origen Board Icon-checked.png Icon-cross.png Icon-cross.png Icon-question.png Icon-question.png Icon-cross.png Icon-checked.png N/A Icon-question.png Icon-checked.png N/A N/A Icon-cross.png Wifi doesn't work with initrd
Video is untested
Arndale Board Icon-question.png Icon-cross.png Icon-cross.png Icon-question.png Icon-question.png Icon-checked.png Icon-checked.png Icon-checked.png Icon-question.png Icon-checked.png N/A Icon-question.png Icon-checked.png Board has WIP stability problems
Video is untested
Samsung Chromebook Icon-checked.png Icon-cross.png Icon-cross.png Icon-cross.png Icon-cross.png Icon-checked.png N/A N/A Icon-checked.png Icon-checked.png Icon-checked.png N/A Icon-cross.png Xorg is not accelerated yet
Touchpad driver configuration is missing
No sound
No webcam

Tests on boards

BeagleBoard-xM

Tests on BeagleBoard-xM:

kernel Boot? Working devices/features Not working devices/features Not tested devices/features Regression compared to previous version?
omap2plus 3.4.6-2.10
(12.2 kernel)
Yes SD/MMC, USB hosts, Ethernet, UART (debug), DSP (working with dsp-tools, gstreamer not tested), CPU freq, Smartreflex (auto voltage), DVI (need to install libdrm_omap1 manually) audio in/out (are we missing this patch?), 2D/3D hardware acceleration (non working kernel modules + libs: work in progress) S-Video/Composite, USB OTG no

SolidRun CuBox

kernel Boot? Working devices/features Not working devices/features Not tested devices/features Regression?
3.5.0-rc2 Yes SD/MMC, USB hosts, UART1, Ethernet, S-ATA Audio, Graphics, HDMI, Video, Powersave

See also